appsignal

Ruby gem 2.5 - JRuby support!

Tom de Bruijn

Tom de Bruijn on

Ruby gem 2.5 - JRuby support!

We just released AppSignal for Ruby gem version 2.5 which adds support for JRuby!

JRuby was previously only available in Ruby gem versions 0.11.18 and lower. Thanks to a recent build process improvement for our extension, we can now produce a build compatible with JRuby.

In this release we now support JRuby in a beta program. If no major issues are reported we'll consider it production ready in the coming months.

Upgrading to the JRuby compatible version

A JRuby compatible version is pushed to RubyGems from now on, which will be picked by JRuby when installing AppSignal. No need for any manual configuration!

If you run your application with JRuby please upgrade to the latest version of the AppSignal Ruby gem and let us know if you experience any problems with this new build.

Please see the changelog for more details about these improvements, deprecations and other changes. And as always: get in touch if you encounter problems after upgrading. We're happy to help!

Share this article

RSS
Tom de Bruijn

Tom de Bruijn

Tom is a developer at AppSignal, organizer, and writer from Amsterdam, The Netherlands.

-> All articles by Tom de Bruijn-> Become an AppSignal author

AppSignal monitors your apps

AppSignal provides insights for Ruby, Rails, Elixir, Phoenix, Node.js, Express and many other frameworks and libraries. We are located in beautiful Amsterdam. We love stroopwafels. If you do too, let us know. We might send you some!

Discover AppSignal
AppSignal monitors your apps